Test jQuery Updates

外掛說明

Test jQuery Updates 是由 WordPress 團隊開發的官方外掛,可在 WordPress 更新 jQuery 及 jQuery UI 前,測試這兩者不同版本的帶來的影響。請勿使用於正式網站。

這個外掛包含 jQuery 3.5.1、jQuery Migrate 3.3.0 及 jQuery UI 1.12.1。jQuery UI 已為了 WordPress 的完整回溯相容性進行重建。

測試項目:

  1. 使用目前 WordPress 內建的 jQuery 版本,但停用 jQuery Migrate。
  2. 最新版本及目前 3.5.1 版的 jQuery,並包含最新版本的 jQuery Migrate。
  3. 最新版本的 jQuery,並包含最新版本的 jQuery Migrate 及 jQuery UI。
  4. 以上均不包含 jQuery Migrate。

如果發現 jQuery 相關的程式碼錯誤,請在這裡回報,外掛設定頁中有相關說明。

預設設定

啟用這個外掛後,不會取代 jQuery 目前版本,但會停用 jQuery Migrate。如需進一步瞭解 jQuery Migrate 的相關資訊,請造訪 jQuery Migrate 的 GitHub 存放庫

使用者評論

2020 年 11 月 8 日
Thanks! Settings that worked for me is jQuery Migrate to Eable, jQuery version to 3.5.1 , jQuery UI version to 1.12.1
閱讀全部 3 則使用者評論

參與者及開發者

以下人員參與了開源軟體〈Test jQuery Updates〉的開發相關工作。

參與者

Test jQuery Updates 外掛目前已有 11 個本地化語言版本。 感謝全部譯者為這個外掛做出的貢獻。

將 Test jQuery Updates 外掛本地化為台灣繁體中文版

對開發相關資訊感興趣?

任何人均可瀏覽程式碼、查看 SVN 存放庫,或透過 RSS 訂閱開發記錄

變更記錄

1.0.1

Update for compatibility with WordPress 5.5-beta1 and newer, allows re-enabling of jQuery Migrate 1.4.1.

1.0.0

Initial release.