WP BrowserUpdate

外掛說明

許多網際網路使用者因為諸多原因 (主要是因為他們不了解更新方式),使用了過期的瀏覽器。改用較新版本的瀏覽器,會有較佳的安全性及可靠性。這個外掛以不直接干擾的方式,通知網站訪客改用較新版本的瀏覽器。僅需安裝並啟用外掛,網站便會開始提供這項通知。

請造訪 browserupdate.org 以進一步了解相關資訊。

如果想要將這個外掛的介面本地化為你的母語版本,請造訪 WordPress 本地化專案頁面以獲得詳細資訊及進行的方式。感謝你的協助。

安裝方式

自行上傳

將解壓縮 wp-browser-update.zip 所得的 wp-browser-update 資料夾上傳至 WordPress 網站的 /wp-content/plugins/ 目錄。

手動安裝

在外掛上傳頁面 (/wp-admin/plugin-install.php?tab=upload) 上傳 wp-browser-update.zip 檔案。

自動安裝

在外掛安裝頁面 (/wp-admin/plugin-install.php) 搜尋「wp browserupdate」,搜尋結果出現後,安裝外掛並啟用。

啟用

不要忘記啟用 WP BrowserUpdate 外掛 ;-)。

使用者評論

2022 年 6 月 3 日
Thank you for your plugin! One vote more for customization of the text 😉
2022 年 4 月 6 日 2 則留言
Thanks, this plugin is really very important. Will you also put the possibility to edit the message
2022 年 3 月 7 日 1 則留言
Crystal clear, low impact plugin that deflects a lot of support issues. All sites should uses this plugin and the browser-update.org service.
2021 年 9 月 17 日
Doesn't work for IE11 which is the main reason I tried this plugin. Also doesn't work if the browser is using uBlock. Good idea but needs much more testing and tweaking.
2020 年 12 月 8 日
But it is missing customization, I think you should be able to change the link and the text
閱讀全部 16 則使用者評論

參與者及開發者

以下人員參與了開源軟體〈WP BrowserUpdate〉的開發相關工作。

參與者

〈WP BrowserUpdate〉外掛目前已有 12 個本地化語言版本。 感謝全部譯者為這個外掛做出的貢獻。

將〈WP BrowserUpdate〉外掛本地化為台灣繁體中文版

對開發相關資訊感興趣?

任何人均可瀏覽程式碼、查看 SVN 存放庫,或透過 RSS 訂閱開發記錄

變更記錄

4.6.2

  • Updated (out-dated) browser versions

4.6.1

  • Removed redundant colons
  • Updated (out-dated) browser versions

4.6

  • Fixed a Cross Site Scripting (XSS) vulnerability
  • Updated (out-dated) browser versions

4.5

  • Fixed a Cross Site Request Forgery (CSRF) vulnerability
  • Updated (out-dated) browser versions

4.4.1

  • Updated (out-dated) browser versions

4.4

  • Changed the source URL
  • Updated (out-dated) browser versions

4.3

4.0

  • Bug fix (thanks to the commenters on the support forum)
  • Updated JavaScript

3.2

  • Corrected typo in version number which rendered this plugin to be outdated

3.1

  • Bug fix (thanks to @tristanmason)
  • Updated (out-dated) browser versions

3.0.3

  • Corrected initialisation error
  • Protocol changed from HTTP to HTTPS
  • Updated (out-dated) browser versions

3.0

  • Overhauled functions
  • Updated JavaScript
  • Updated (out-dated) browser versions

2.4

  • Corrected functions

2.3

  • Overhauled functions
  • Updated translation files
  • Minor bug fix

2.2

  • Changed license from GPLv2 to GPLv3
  • Added text domain in plugin header
  • Added POT file in ./languages folder for easier i18n 😉

2.1.3

  • Included minified JavaScript (forgot to switch back after some testing)
  • Minor fix of initial notification message (thanks to Matthias Van Dooren)

2.1

  • Added options to customize the JavaScript (thanks to Tomas Risberg)

2.0.3

  • Updated (out-dated) browser versions
  • Updated JavaScript
  • Added settings link to plugin overview page
  • Minor bug fix

2.0

  • Added administration panel for individual modifications
  • Added uninstall function

1.0

  • Stable version