環境需求

如需以 WordPress 建置網站,我們建議採用符合以下規格的主機:

滿足以上所述規格即可。建議採用強大且功能豐富的 ApacheNginx 作為網頁伺服器以執行 WordPress,但也可以採用其他可執行 PHP 及 MySQL 的網頁伺服器。也就是說,我們無法無法為所有能執行 WordPress 的主機環境進行測試,而每一家列於 WordPress 網站主機託管頁面的服務上均支援以上規格,不會產生其他問題。

請注意,如果網站執行於只有舊版 PHP 及 MySQL 的老舊環境,WordPress 仍可執行於 PHP 5.6.20+ 及 MySQL 5.0+,但這些版本均已達官方宣布的生命週期結束期限,可能會讓網站暴露在安全性漏洞的風險中

與主機商洽詢

以下是使用者可以用來與主機服務提供商溝通的電子郵件範本,僅需複製及貼上。

我非常想執行開源架站軟體 WordPress <https://wordpress.org/>,因此我想瞭解我使用的方案是否支援以下規格:

  • PHP 7.3 或更新版本
  • MySQL 5.6 或更新版本、MariaDB 10.0 或更新版本
  • 已安裝 mod_rewrite 模組的 Nginx 或 Apache
  • 支援 HTTPS

感謝回覆!

非絕對必要,但可以獲得更高安全性的建議

不使用伺服器預設的共用使用者名稱,而是使用專屬帳號的使用者名稱去執行像 WordPress 這類 PHP 應用程式時,主機會更加安全。請洽詢你有意採用的主機服務提供商,他們採取了哪些措施來確保使用者帳號的安全性。