這個外掛並未在最新的 3 個 WordPress 主要版本上進行測試。開發者可能不再對這個外掛進行維護或提供技術支援,並可能會與更新版本的 WordPress 產生使用上的相容性問題。

Link Juice Keeper

外掛說明

As you probably know, incoming links play important role in ranking well in Google and other search engines. Therefore you should assure that every incoming link leads to one of pages on your blog. This may be a challenge, because World Wide Web is dynamic and changes every day:

  • you can remove some posts or pages on your blog;
  • you can change URL scheme on whole blog;
  • incoming links may became broken (e.g. due to some automatic text formatting);
  • someone may simply put wrong (broken) link somewhere.

All of the above leads to link juice waste. You can avoid this by using this plugin. It redirects all non-existing URLs which normally return a 404 error to the blog front page using 301 (permanent) redirect. This way everyone who comes to your blog via broken link (both people and robots) will be redirected to the front page.

The only one exception are files in root blog directory with names starting with noexist_. They are used by Google to verify page in Google Webmasters Tools, so Link Juice Keeper does not redirect them.

Changelog

安裝方式

  1. Upload link-juice-keeper directory to the /wp-content/plugins/ directory
  2. Activate the plugin through the ‘Plugins’ menu in WordPress
  3. Configure and enjoy 🙂

常見問題集

Installation Instructions
  1. Upload link-juice-keeper directory to the /wp-content/plugins/ directory
  2. Activate the plugin through the ‘Plugins’ menu in WordPress
  3. Configure and enjoy 🙂

貢獻者及開發者

Link Juice Keeper 外掛為開源軟體。以下人員對這個外掛做出了貢獻。

貢獻者

將 Link Juice Keeper 外掛以你的母語進行本地化。

對開發相關資訊感興趣?

任何人均可瀏覽程式碼、查看 SVN 存放庫,或透過 RSS 訂閱開發記錄

變更記錄

1.2.3

  • Marked as compatible with WP 3.2.x

1.2.2

  • Marked as compatible with WP 2.9.x

1.2.1

  • Marked as compatible with WP 2.8.5

1.2

  • Fix: does not redirect Google Bot doing page verification for Google Webmasters Tools

1.1.1

  • Make plugin compatible with WordPress 2.8

1.1

  • Decreased filter priority, so now it will run after ones with default priority

1.0

  • Initial version