這個外掛並未在最新的 3 個 WordPress 主要版本上進行測試。開發者可能不再對這個外掛進行維護或提供技術支援,並可能會與更新版本的 WordPress 產生使用上的相容性問題。

Faster Appearance – Menus

外掛說明

The new accessibility javascript in the Appearance > Menus panel in WordPress 3.6 can significantly slow the page load speed when using a large number of menu items (> 50). This plugin defers the accessibility processing to eliminate the scripting bottleneck and allow the Appearance > Menus screen to run much faster and more responsively.

Full details

This solution is fairly rough. Hopefully we can develop a robust solution that can eventually become part of the core. Pull requests through GitHub are welcome.

螢幕擷圖

  • Faster Menu Management

安裝方式

  1. Upload the faster-appearance-menus directory to the /wp-content/plugins/ directory, or install via the Plugins uploader
  2. Activate the plugin through the ‘Plugins’ menu in WordPress
  3. Enjoy faster menu management

常見問題集

What are you on about?

Please read this

使用者評論

2016 年 9 月 3 日
Awesome plugin! I have more than 100 items in the menu and it was a nightmare when I needed to add more or just to reorder the current ones. After installing this awesome plugin everything is so smooth and fast. Thank you for sharing this plugin!
2016 年 9 月 3 日
i downloaded the plug in and it doesnt work with the new 4.4 wordpress version. does someone brought it to work with 4.4??? why is wordrpess not able to solve this long time issue with the stupid f. up menu problems, and cut of menu navi items if longer as 80 wiht a slower php setting. this is so long known and wordpress does nothing against it. with my long wordpress menu i have to move ot another host and it is a pain in the a. please update your plug in for wordpress 4.4 since the programmeers at wordpress are not able to solve this issue by themselfe.. thanks
閱讀全部 29 則使用者評論

參與者及開發者

以下人員參與了開源軟體〈Faster Appearance – Menus〉的開發相關工作。

參與者

將 Faster Appearance – Menus 外掛本地化為台灣繁體中文版

對開發相關資訊感興趣?

任何人均可瀏覽程式碼、查看 SVN 存放庫,或透過 RSS 訂閱開發記錄

變更記錄

0.1.1

  • Updated script replacement strategy to preserve script dependencies

0.1

  • Initial version