這個外掛並未在最新的 3 個 WordPress 主要版本上進行測試。開發者可能不再對這個外掛進行維護或提供技術支援,並可能會與更新版本的 WordPress 產生使用上的相容性問題。

ACF Enhanced Message Field

外掛說明

This field will provide you more options and flexibility on how you would like to present an instruction or message to your client’s (or site in general) admin interface.

Features:

  • Support PHP.
  • Option to hide label when field is displayed.

Compatible with Advanced Custom Fields:

  • 4 (tested up to 4.4.6)
  • 5 (PRO, tested up to 5.3.7)

PS: You need Advanced Custom Fields installed to use this.

PPS: Even more awesome if you have Advanced Custom Fields PRO installed.

Important note: Use this with utmost care.

安裝方式

  1. Check and make sure you have installed Advanced Custom Fields.
  2. Upload ‘acf-enhanced-message’ to your ‘/wp-content/plugins/’ folder.
  3. Go ahead and activate the plugin in the ‘Plugins’ admin page in WordPress.
  4. Create a field group and check ‘Enhanced Message’ (under Layout) that is now available.

常見問題集

You: Should I include PHP tags

Me: Yes.

You: I have more questions or found an issue

Me: Reach out on WordPress support and discussion forums or Github issues

使用者評論

2018 年 8 月 6 日
Exactly what I needed. You could improve the plugin by making the textarea field look more like an IDE, with system fonts, syntax highlights and so on.
2017 年 7 月 31 日
Worst plugin ever. Horribly incomplete documentation. Was never able to get any support. Never got it working right. I'd keep complaining but i don't think i can in my swear words any longer.
閱讀全部 7 則使用者評論

參與者及開發者

以下人員參與了開源軟體〈ACF Enhanced Message Field〉的開發相關工作。

參與者

將〈ACF Enhanced Message Field〉外掛本地化為台灣繁體中文版

對開發相關資訊感興趣?

任何人均可瀏覽程式碼、查看 SVN 存放庫,或透過 RSS 訂閱開發記錄

變更記錄

1.1.1

  • Fix: don’t process load field outside admin interface

1.1.0

  • Compatible with ACF 4.4.6 and ACF Pro 5.3.7
  • Prevent class conflict if this plugin is already added directly in your plugin/theme.
  • Fix: Prevent style being printed in json export

1.0.1

  • Fix: Updated the prefix of group fields to hide again fields that are not necessary/required.

1.0

  • First release, fresh and innocent but will get you there.